diff options
author | John Glover <j@johnglover.net> | 2012-08-12 17:34:48 +0100 |
---|---|---|
committer | John Glover <j@johnglover.net> | 2012-08-12 17:34:48 +0100 |
commit | d9e5c35b9bbec5649d217ffc929cae7e4ee79f5a (patch) | |
tree | c5d46e7a8f6c4f2878a08eac05ff73a7114e4b19 /setup.py | |
parent | 5d003fd462ad8de027730bc406d8a81ff33e2531 (diff) | |
download | simpl-d9e5c35b9bbec5649d217ffc929cae7e4ee79f5a.tar.gz simpl-d9e5c35b9bbec5649d217ffc929cae7e4ee79f5a.tar.bz2 simpl-d9e5c35b9bbec5649d217ffc929cae7e4ee79f5a.zip |
Remove old SWIG modules.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 19 |
1 files changed, 1 insertions, 18 deletions
@@ -33,7 +33,6 @@ except ImportError: macros = [] link_args = [] -swig_opts = ['-c++'] include_dirs = ['simpl', 'src/simpl', 'src/sms', 'src/sndobj', 'src/sndobj/rfftw', numpy_include, '/usr/local/include'] libs = ['m', 'fftw3', 'gsl', 'gslcblas'] @@ -76,21 +75,6 @@ sndobj_sources = map(lambda x: 'src/sndobj/' + x, sndobj_sources) sndobj_sources.extend(map(lambda x: 'src/sndobj/rfftw/' + x, fftw_sources)) sources.extend(sndobj_sources) -sndobj_sources.append("simpl/sndobj.i") - -sndobj_macros = [('PYTHON_WRAP', None)] -sndobj_macros.extend(macros) -sndobj_swig_opts = ['-c++', '-DNUMPY'] -sndobj_swig_opts.extend(swig_opts) -sndobj_include_dirs = ['src/sndobj/rfftw', 'src/sndobj'] -sndobj_include_dirs.extend(include_dirs) - -sndobj = Extension("simpl/_simplsndobj", - sources=sndobj_sources, - include_dirs=sndobj_include_dirs, - define_macros=sndobj_macros, - swig_opts=sndobj_swig_opts) - # ----------------------------------------------------------------------------- # SMS # ----------------------------------------------------------------------------- @@ -182,8 +166,7 @@ setup( author_email='j@johnglover.net', platforms=["Linux", "Mac OS-X", "Unix", "Windows"], version='0.3', - ext_modules=[base, peak_detection, partial_tracking, - synthesis, residual, sndobj], + ext_modules=[base, peak_detection, partial_tracking, synthesis, residual], cmdclass={'build_ext': build_ext}, packages=['simpl', 'simpl.plot'] ) |