summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Glover <j@johnglover.net>2012-08-22 16:44:52 +0100
committerJohn Glover <j@johnglover.net>2012-08-22 16:44:52 +0100
commite4ab5141d33d0c94a1c82091a02cfc7ecffc65fd (patch)
tree1279128c939768c209dbffb94419ec5c8e54cefb /CMakeLists.txt
parent5fb34d7d5451cefd88bb9d7a0d9c442d67caf143 (diff)
downloadsimpl-e4ab5141d33d0c94a1c82091a02cfc7ecffc65fd.tar.gz
simpl-e4ab5141d33d0c94a1c82091a02cfc7ecffc65fd.tar.bz2
simpl-e4ab5141d33d0c94a1c82091a02cfc7ecffc65fd.zip
[loris] Add C++ implementation of LorisPartialTracking.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c5aa23..1a79a5e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,8 +42,14 @@ install(FILES ${include_files} DESTINATION include/simpl)
# tests
set(test_base_src ${source_files} tests/test_base.cpp)
set(test_peak_detection_src ${source_files} tests/test_peak_detection.cpp)
+set(test_partial_tracking_src ${source_files} tests/test_partial_tracking.cpp)
+
LIST(APPEND libs cppunit sndfile)
+
add_executable(test_base ${test_base_src})
add_executable(test_peak_detection ${test_peak_detection_src})
+add_executable(test_partial_tracking ${test_partial_tracking_src})
+
target_link_libraries(test_base ${libs})
target_link_libraries(test_peak_detection ${libs})
+target_link_libraries(test_partial_tracking ${libs})