summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Glover <j@johnglover.net>2012-08-23 17:57:56 +0100
committerJohn Glover <j@johnglover.net>2012-08-23 17:57:56 +0100
commit18ccab0e26a692073c2cd7d3c13d0c289b8f748f (patch)
treef3751dcd5b017f07a12f916a9d6cda8f9d7d19c6 /CMakeLists.txt
parente160337c4e45c53772f2c311aef1a7429e73ab51 (diff)
downloadsimpl-18ccab0e26a692073c2cd7d3c13d0c289b8f748f.tar.gz
simpl-18ccab0e26a692073c2cd7d3c13d0c289b8f748f.tar.bz2
simpl-18ccab0e26a692073c2cd7d3c13d0c289b8f748f.zip
[loris] Add C++ implementation of LorisSynthesis.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a79a5e..cdc6d0e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,13 +43,16 @@ install(FILES ${include_files} DESTINATION include/simpl)
set(test_base_src ${source_files} tests/test_base.cpp)
set(test_peak_detection_src ${source_files} tests/test_peak_detection.cpp)
set(test_partial_tracking_src ${source_files} tests/test_partial_tracking.cpp)
+set(test_synthesis_src ${source_files} tests/test_synthesis.cpp)
LIST(APPEND libs cppunit sndfile)
add_executable(test_base ${test_base_src})
add_executable(test_peak_detection ${test_peak_detection_src})
add_executable(test_partial_tracking ${test_partial_tracking_src})
+add_executable(test_synthesis ${test_synthesis_src})
target_link_libraries(test_base ${libs})
target_link_libraries(test_peak_detection ${libs})
target_link_libraries(test_partial_tracking ${libs})
+target_link_libraries(test_synthesis ${libs})