aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRichard Knight <q@1bpm.net>2021-07-09 17:35:01 +0100
committerRichard Knight <q@1bpm.net>2021-07-09 17:35:01 +0100
commit1b40e87a3f54a70d4994262dd7fad4297caaeca3 (patch)
treee70a190201d4a348daff0234769653e9eb262257 /CMakeLists.txt
parent6002b975544934cf8127040257ce630d8bc0d279 (diff)
downloadcsound-sqldb-1b40e87a3f54a70d4994262dd7fad4297caaeca3.tar.gz
csound-sqldb-1b40e87a3f54a70d4994262dd7fad4297caaeca3.tar.bz2
csound-sqldb-1b40e87a3f54a70d4994262dd7fad4297caaeca3.zip
moved from libpqxx to libpq
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43c251d..fb38a90 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,7 @@ set(BUILDING_CSOUND_PLUGINS ON)
# ----------------------------------------------
include(FindCsound)
-include(FindPQXX)
+include(FindPostgreSQL)
include(FindSqlite3)
include(FindMySQL)
@@ -154,7 +154,7 @@ if(NOT CSOUND_FOUND)
message(FATAL_ERROR "Csound installation not found")
endif()
-if(NOT PQXX_FOUND AND NOT SQLITE3_FOUND AND NOT MYSQLCONNECTORCPP_FOUND)
+if(NOT PostgreSQL_FOUND AND NOT SQLITE3_FOUND AND NOT MYSQLCONNECTORCPP_FOUND)
message(FATAL_ERROR "No database libraries could be found")
endif()
@@ -168,7 +168,7 @@ endif()
set(CPPFILES src/opcodes.cpp src/connection.cpp)
-if (PQXX_FOUND)
+if (PostgreSQL_FOUND)
message(STATUS "Using PostgreSQL")
list(APPEND CPPFILES "src/postgresql.cpp")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DBUILD_POSTGRES")
@@ -192,9 +192,9 @@ endif()
include_directories(${CSOUND_INCLUDE_DIRS})
include_directories(include)
-if (PQXX_FOUND)
- link_libraries(${PQXX_LIBRARIES})
- include_directories(${PQXX_INCLUDE_DIRECTORIES})
+if (PostgreSQL_FOUND)
+ link_libraries(${PostgreSQL_LIBRARIES})
+ include_directories(${PostgreSQL_INCLUDE_DIRS})
endif()
if (SQLITE3_FOUND)